Package affine-contracts.plt contributed by tov [docs]
To load: (require (planet tov/affine-contracts:2:2))
Old style:(require (planet "main.ss" ("tov" "affine-contracts.plt" 2 2)))
Min Racket version: 4.1.4
Package description:
Affine contracts for one-shot functions and boxes
Downloads this week: 0
Total downloads: 62
Tickets:1
Open tickets:0
Primary files:
[no interface available]
 Current version
PLaneT versionExternal versionSourceDLsDocsReq. PLTDate added
(2 2)0.2.1
50
4.1.42009-05-03
To load: (require (planet tov/affine-contracts:2:2))
Available in repositories: 4.x
  • 0.2.0: Added facilities for defining new types of affine boxes.
  • Unclear what the required version of PLT Scheme should be. However, we use an undocumented contract accessor proj-get, so it definitely depends on that. It's known to work with 4.1.4.2, but I suspect that's overly restrictive.
  • Initial release
No Tickets Currently open for this Package [New Ticket]

 Old versions
PLaneT versionExternal versionSourceDLsDocsReq. PLTDate added
(2 1)0.2.1
1
4.1.42009-04-24
To load: (require (planet "main.ss" ("tov" "affine-contracts.plt" 2 (= 1))))
Available in repositories: 4.x
  • 0.2.0: Added facilities for defining new types of affine boxes.
  • Unclear what the required version of PLT Scheme should be. However, we use an undocumented contract accessor proj-get, so it definitely depends on that. It's known to work with 4.1.4.2, but I suspect that's overly restrictive.
  • Initial release
(2 0)0.2.0
1
4.1.42009-04-24
To load: (require (planet "main.ss" ("tov" "affine-contracts.plt" 2 (= 0))))
Available in repositories: 4.x
  • 0.2.0: Added facilities for defining new types of affine boxes.
  • Unclear what the required version of PLT Scheme should be. However, we use an undocumented contract accessor proj-get, so it definitely depends on that. It's known to work with 4.1.4.2, but I suspect that's overly restrictive.
  • Initial release
(1 1)0.1.1
9
4.1.42009-04-22
To load: (require (planet "main.ss" ("tov" "affine-contracts.plt" 1 (= 1))))
Available in repositories: 4.x
  • Initial release
  • Unclear what the required version of PLT Scheme should be. However, we use an undocumented contract accessor proj-get, so it definitely depends on that. It's known to work with 4.1.4.2, but I suspect that's overly restrictive.
(1 0)0.1
1
[none]2009-04-21
To load: (require (planet "main.ss" ("tov" "affine-contracts.plt" 1 (= 0))))
Available in repositories: 4.x
  • Initial release
  • Unclear what the required version of PLT Scheme should be. However, we use an undocumented contract accessor proj-get, so it definitely depends on that. It's known to work with 4.1.4.2, but I suspect that's overly restrictive.