Package fasttest.plt contributed by cce [docs]
To load: (require (planet cce/fasttest:4:2/random))
Old style:(require (planet "random.rkt" ("cce" "fasttest.plt" 4 2)))
Min Racket version: 4.2.5
Package description:
FastTest random test case generation. Inspired by the QuickCheck library for Haskell.
Downloads this week: 0
Total downloads: 2531
Tickets:1
Open tickets:1
Primary files:
[no interface available]
 Current version
PLaneT versionExternal versionSourceDLsDocsReq. PLTDate added
(4 2)
99
4.2.52011-11-28
To load: (require (planet cce/fasttest:4:2/random))
Available in repositories: 4.x
4.2: Compatibility with Racket 5.2.0.4.
 Open tickets
[All Tickets] [New Ticket]
Ticket IdOwnerReporterTypeVersion
327ccejmj@…defect(3 9)
require error on installing

 Old versions
PLaneT versionExternal versionSourceDLsDocsReq. PLTDate added
(4 1)
71
4.2.52011-09-02
To load: (require (planet "random.rkt" ("cce" "fasttest.plt" 4 (= 1))))
Available in repositories: 4.x
4.1: Fixed error message; no longer uses DoubleCheck terminology or suggests solutions.
(4 0)
2
4.2.52011-09-02
To load: (require (planet "random.rkt" ("cce" "fasttest.plt" 4 (= 0))))
Available in repositories: 4.x
4.0: Now uses RackUnit rather than SchemeUnit.
(3 10)
95
4.2.52011-04-21
To load: (require (planet "random.ss" ("cce" "fasttest.plt" 3 (= 10))))
Available in repositories: 4.x
3.10: Updated for compatibility with Racket v5.1.1.
(3 9)
94
4.22011-02-04
To load: (require (planet "random.ss" ("cce" "fasttest.plt" 3 (= 9))))
Available in repositories: 4.x
3.9: Updated for compatibility with Racket v5.1.
(3 8)
352
4.22010-05-28
To load: (require (planet "random.ss" ("cce" "fasttest.plt" 3 (= 8))))
Available in repositories: 4.x
3.8: Updated for compatibility with upcoming Racket release.
(3 7)
58
4.22010-03-22
To load: (require (planet "random.ss" ("cce" "fasttest.plt" 3 (= 7))))
Available in repositories: 4.x
3.7: Improved error message when generators fail to satisfy their guard.
(3 6)
372
4.22009-09-30
To load: (require (planet "random.ss" ("cce" "fasttest.plt" 3 (= 6))))
Available in repositories: 4.x
3.6: Updated for compatibility with PLT Scheme versions 4.2 - 4.2.2.
(3 5)
851
[none]2009-03-10
To load: (require (planet "random.ss" ("cce" "fasttest.plt" 3 (= 5))))
Available in repositories: 4.x
3.5: Updated documentation to avoid broken links on planet server.
(3 4)
38
[none]2009-02-12
To load: (require (planet "random.ss" ("cce" "fasttest.plt" 3 (= 4))))
Available in repositories: 4.x
3.4: Minor updates to documentation.
(3 3)
67
[none]2009-01-16
To load: (require (planet "random.ss" ("cce" "fasttest.plt" 3 (= 3))))
Available in repositories: 4.x
3.3: Compatibility with updates to scheme/sandbox, cce/scheme.plt.
(3 2)
84
[none]2008-09-23
To load: (require (planet "random.ss" ("cce" "fasttest.plt" 3 (= 2))))
Available in repositories: 4.x
3.2: Added documentation.
(3 1)
60
[none]
[none]2008-08-27
To load: (require (planet "random.ss" ("cce" "fasttest.plt" 3 (= 1))))
Available in repositories: 4.x
3.1: Improved GUI output. Documentation still to come.
(3 0)
23
[none]
[none]2008-08-25
To load: (require (planet "random.ss" ("cce" "fasttest.plt" 3 (= 0))))
Available in repositories: 4.x
3.0: Updated interface. Documentation to come.
(2 0)
71
[none]
[none]2008-06-09
To load: (require (planet "random.ss" ("cce" "fasttest.plt" 2 (= 0))))
Available in repositories: 4.x
2.0: updated for PLT Scheme 4.0 compatibility. Known style issues:
  • does not have Scribble documentation,
  • does not use new keyword arguments,
  • does not use main.ss convention.
 Packages in other repositories

These packages are not available in the 4.x repository, but they are available for other versions of Racket.

PLaneT versionExternal versionSourceDLsDocsReq. PLTDate added
(1 4)
20
3712008-05-15
To load: (require (planet "random.ss" ("cce" "fasttest.plt" 1 (= 4))))
Available in repositories: 3xx
1.4: failed generation attempts now display list of unsatisfactory values
(1 3)
0
3712008-05-15
To load: (require (planet "random.ss" ("cce" "fasttest.plt" 1 (= 3))))
Available in repositories: 3xx
1.3:
  • changed default random characters to capital letters
  • changed random/choose-int-between contract to require i <= j
  • changed schemeunit annotation from 'FastTest x' to 'random-x'
  • (1 2)
    164
    3712007-11-11
    To load: (require (planet "random.ss" ("cce" "fasttest.plt" 1 (= 2))))
    Available in repositories: 3xx
    • 1.2: Added new options to generate. Added define-generator, let*-random, and check-randomly. Corrected and updated documentation.
    • 1.1: Bug fixes, interface changes.
    • 1.0: Initial release.
    (1 1)
    7
    3702007-10-29
    To load: (require (planet "random.ss" ("cce" "fasttest.plt" 1 (= 1))))
    Available in repositories: 3xx
    • 1.1: Bug fixes, interface changes.
    • 1.0: Initial release.
    (1 0)
    3
    3702007-10-26
    To load: (require (planet "random.ss" ("cce" "fasttest.plt" 1 (= 0))))
    Available in repositories: 3xx
    1.0: Initial release.