Package guiml.plt contributed by jphelps [docs]
To load: (require (planet jphelps/guiml:3:2))
Old style:(require (planet "main.rkt" ("jphelps" "guiml.plt" 3 2)))
Package description:
A DSL for building GUIs easily. Write GUIs in an HTML-like hierarchical notation. Objects within the resulting tree can be pulled out by their ID or their class.
Downloads this week: 1
Total downloads: 111
Tickets:0
Open tickets:0
Primary files:
[no interface available]
 Current version
PLaneT versionExternal versionSourceDLsDocsReq. PLTDate added
(3 2)
10
[none]2015-03-23
To load: (require (planet jphelps/guiml:3:2))
Available in repositories: 4.x
GUIML now creates real racket/gui objects instead of wrapping them in structs and listsDocumentation has been expanded.
No Tickets Currently open for this Package [New Ticket]

 Old versions
PLaneT versionExternal versionSourceDLsDocsReq. PLTDate added
(3 1)
0
[none]2015-03-22
To load: (require (planet "main.rkt" ("jphelps" "guiml.plt" 3 (= 1))))
Available in repositories: 4.x
GUIML now creates real racket/gui objects instead of wrapping them in structs and listsDocumentation has been expanded.
(3 0)
0
[none]2015-03-18
To load: (require (planet "main.rkt" ("jphelps" "guiml.plt" 3 (= 0))))
Available in repositories: 4.x
GUIML now creates real racket/gui objects instead of wrapping them in structs and listsDocumentation has been expanded.
(2 4)
62
[none]2011-05-02
To load: (require (planet "main.rkt" ("jphelps" "guiml.plt" 2 (= 4))))
Available in repositories: 4.x
Fixed the bug where (sendmsg foo) evaluates foo twice.Also revised the documentation.
(2 3)
15
[none]2010-12-18
To load: (require (planet "main.rkt" ("jphelps" "guiml.plt" 2 (= 3))))
Available in repositories: 4.x
Fixed the bug where (sendmsg foo) evaluates foo twice.Also revised the documentation.
(2 2)
4
[none]2010-12-02
To load: (require (planet "main.rkt" ("jphelps" "guiml.plt" 2 (= 2))))
Available in repositories: 4.x
[no release notes]
(2 1)
4
[none]2010-12-02
To load: (require (planet "main.rkt" ("jphelps" "guiml.plt" 2 (= 1))))
Available in repositories: 4.x
[no release notes]
(2 0)
1
[none]2010-12-02
To load: (require (planet "main.rkt" ("jphelps" "guiml.plt" 2 (= 0))))
Available in repositories: 4.x
[no release notes]
(1 1)
15
[none]2010-09-19
To load: (require (planet "guiml.scm" ("jphelps" "guiml.plt" 1 (= 1))))
Available in repositories: 4.x
[no release notes]
(1 0)
0
[none]2010-09-19
To load: (require (planet "guiml.scm" ("jphelps" "guiml.plt" 1 (= 0))))
Available in repositories: 4.x
[no release notes]