#lang setup/infotab

(define name "User Script Plugin")
(define drracket-names '("Script Plugin"))
(define drracket-tools '("tool.rkt"))

(define scribblings '(("manual.scrbl")))

(define blurb 
  '("DrRacket plugin to enable easy user scripting for the definition window. Similar to GEdit External Tools."))

(define required-core-version "5.0")
(define repositories '("4.x"))
(define categories '(devtools))

(define can-be-loaded-with 'none)
(define primary-file "tool.rkt")

(define version "0.3")
(define release-notes
     (li "Note: The 0.x external version branch (PLaneT 1.x branch) is considered unstable, and there may be some backward incompatibilities.")
     (li "Renamed transform-input-string to modify-selection.")
     (li "Removed #:file-string keyword (duplicate with #:file-path) and renamed #:file-path to #:file.")
     (li "Added #:frame and fixed #:editor (now uses dynamic-require instead of eval).")
     (li "Added Help menu item and updated docs.")
     (li "Better error checking/reporting (displayed in a message-box).")