Ticket #102 (closed defect)

Opened 10 years ago

Last modified 10 years ago

server doesn't run (libcrypto error, etc)

Reported by: vegashacker Owned by: vegashacker
Priority: major Milestone:
Component: vegashacker/leftparen.plt Keywords:
Cc: Version: (2 2)
Racket Version: 4.1

Description

Reported via email:

The server doesn't run: when I tried running the script (after fixing the path to the binary), first I got this:

default-load-handler: cannot open input file:
"/home/marek/.plt-scheme/planet/300/4.1.1/cache/untyped/mirrors.plt/1/3/doc/mirrors.scrbl" (No such file or directory; errno=2)

I couldn't reproduce this so far, but now I'm getting this:

ffi-lib: couldn't open "libcrypto.so" (libcrypto.so: cannot open shared object file: No such file or directory)

libcrypto.so is part of libssl-dev in Debian and most likely not installed on most computers. What is available is libcrypto.so.0.9.8 from the libssl0.9.8 package, which has a wide installation base since it is a central part of the SSL ecosystem.

Change History

Changed 10 years ago by vegashacker

  • status changed from new to accepted

The first issue may just be a PLaneT cache-related upgrade thing. I've experienced similar issues when upgrading to new versions of PLT Scheme. Sometimes I find it helpful just to remove my planet cache entirely.

This thread seems very relevant to the second issue:  http://www.cs.brown.edu/pipermail/plt-scheme/2007-February/016356.html

LeftParen? uses digest.plt in user.scm to do md5 hashes.

Changed 10 years ago by soegaard

Since md5 us only used to calculate the digest of a short string (password + salt),
maybe the simplest solution is to use the builtin md5 routine which is written in Scheme
(and thus does not rely on any external library)?

Changed 10 years ago by vegashacker

I resolved this issue by removing the dependency on the digest library, as per soegaard's suggestion. Here's the patch:
 http://github.com/vegashacker/leftparen/commit/9ebdbfbdea0ec21b0a1092b9890cc62afd704984

I'll resolve this ticket when I do the next PLaneT release.

Changed 10 years ago by vegashacker

  • status changed from accepted to closed

LeftParen? 0.4 (version (3 0) on PLaneT) is out, and this bug is fixed in it.

Note: See TracTickets for help on using tickets.