Ticket #142 (closed defect)

Opened 6 years ago

Last modified 5 years ago

incompatible with planet dherman/memoize:3:1

Reported by: eric.hanchrow@… Owned by: soegaard
Priority: major Milestone:
Component: soegaard/math.plt Keywords:
Cc: Version: (1 3)
Racket Version: 4.1.3

Description

$ mzscheme --version
Welcome to MzScheme? v4.1.3 [3m], Copyright (c) 2004-2008 PLT Scheme Inc.

$ cat > simple.ss <<EOF
#lang scheme
(require (planet dherman/memoize:3:1)

(planet soegaard/math:1:3/math))

EOF

$ mzscheme simple.ss
Package memoize.plt loaded twice with multiple incompatible versions:
[unknown] attempted to load version 2.3 while version 3.1 was already loaded by /tmp/simple.ss

context


/usr/local/stow/plt/lib/plt/collects/planet/resolver.ss:282:7
/usr/local/stow/plt/lib/plt/collects/scheme/private/map.ss:44:11: for-each
/usr/local/stow/plt/lib/plt/collects/planet/resolver.ss:275:0: add-pkg-to-diamond-registry!
/usr/local/stow/plt/lib/plt/collects/planet/resolver.ss:321:0: planet-resolve

Change History

Changed 5 years ago by soegaard

  • status changed from new to closed

Fixed in 1.4. Thanks for the report.

Note: See TracTickets for help on using tickets.