Ticket #321 (closed defect: worksforme)

Opened 3 years ago

Last modified 3 years ago

compile: unbound identifier error when using neil/sicp with DrRacket 5.1.

Reported by: anonymous Owned by: neil
Priority: critical Milestone:
Component: neil/sicp.plt Keywords:
Cc: Version:
Racket Version: 5.1

Description

*** Description:
compile: unbound identifier (and no #%app syntax transformer is
bound) in: #%top-interaction error when using neil/sicp with
DrRacket?.

*** How to repeat:
1. Make sure '#lang planet neil/sicp' is present in your automatic
language line. If not, add it and restart DrRacket?.
2. Write anything at the input prompt. It should fail with
'compile: unbound identifier (and no #%app syntax transformer is
bound) in: #%top-interaction'
3. Click on the 'Run' button at the top.
4. Rewrite the same expression as before. We no longer get the same
issue and we will get the expected response to the written
expresion.

*** Environment:
windows "Windows NT 6.1 (Build 7600)" (win32\i386\3m)
(get-display-depth) = 32
Human Language: english
(current-memory-use) 118804572

Collections:
("C:\\Users\\Administrator\\AppData?\\Roaming\\Racket\\5.1\\collects"
(non-existent-path))
("C:\\Program Files (x86)\\Racket\\collects"
("2htdp" "algol60" "at-exp" "browser" "combinator-parser"
"compiler" "config" "data" "datalog" "defaults" "deinprogramm"
"drracket" "drscheme" "dynext" "embedded-gui" "eopl" "errortrace"
"ffi" "file" "framework" "frtime" "games" "graphics" "gui-debugger"
"help" "hierlist" "htdp" "html" "icons" "info-domain" "lang"
"launcher" "lazy" "macro-debugger" "make" "mred" "mrlib" "mysterx"
"mzcom" "mzlib" "mzscheme" "net" "openssl" "parser-tools"
"picturing-programs" "plai" "planet" "plot" "preprocessor"
"profile" "r5rs" "r6rs" "racket" "racklog" "rackunit" "raco"
"reader" "readline" "redex" "rnrs" "s-exp" "scheme" "schemeunit"
"scribble" "scribblings" "scriblib" "setup" "sgl" "slatex"
"slideshow" "srfi" "stepper" "string-constants" "swindle" "syntax"
"syntax-color" "teachpack" "test-box-recovery" "test-engine"
"tex2page" "texpict" "trace" "typed" "typed-scheme" "unstable"
"version" "web-server" "wxme" "xml"))

Computer Language: (("Determine language from source") (#(#t print
mixed-fraction-e #f #t debug) (default) #() "#lang planet
neil/sicp\n" #t #t))

Change History

Changed 3 years ago by neil

  • status changed from new to closed
  • resolution set to worksforme

Could not reproduce this under DrRacket? 5.1 (on Linux x86 32-bit) two months ago, after trying several different ways.

Briefly tried to reproduce it under DrRacket? 5.1.1 (on both Linux and Windows, x86 32-bit) just now, and still could not.

No one else has reported this problem yet, so I'm wondering whether there is something unusual about the reporter's setup that is triggering or causing this problem. Reporter is anon. I'm inclined to mark this irreproducible. It can be revisited if the problem is reported again by anyone.

Note: See TracTickets for help on using tickets.