Package plt-linalg.plt contributed by wmfarr [docs]
To load: (require (planet wmfarr/plt-linalg:1:13/all))
Old style:(require (planet "all.rkt" ("wmfarr" "plt-linalg.plt" 1 13)))
Min Racket version: 5.0
Package description:
Simple linear algebra operations in double-precision for PLT Scheme.Uses LAPACK and BLAS for operations
Downloads this week: 1
Total downloads: 431
Tickets:2
Open tickets:0
Primary files:
[no interface available]
 Current version
PLaneT versionExternal versionSourceDLsDocsReq. PLTDate added
(1 13)
146
5.02010-08-15
To load: (require (planet wmfarr/plt-linalg:1:13/all))
Available in repositories: 4.x
Added eigensystem to matrix.rkt, disabled matrix-solve-least-squares due to segfault.
No Tickets Currently open for this Package [New Ticket]

 Old versions
PLaneT versionExternal versionSourceDLsDocsReq. PLTDate added
(1 12)
10
[none]2010-08-12
To load: (require (planet "all.ss" ("wmfarr" "plt-linalg.plt" 1 (= 12))))
Available in repositories: 4.x
Updated paths for special Debian BLAS and LAPACK libraries.
(1 11)
49
[none]2009-08-10
To load: (require (planet "all.ss" ("wmfarr" "plt-linalg.plt" 1 (= 11))))
Available in repositories: 4.x
Updated linux paths to add /usr/libsse2 per bug report #196.
(1 10)
42
[none]2009-01-06
To load: (require (planet "all.ss" ("wmfarr" "plt-linalg.plt" 1 (= 10))))
Available in repositories: 4.x
Reverted to the reference implementation of SRFI-42 due to syntax certificate bugs.
(1 9)
14
[none]2008-12-06
To load: (require (planet "all.ss" ("wmfarr" "plt-linalg.plt" 1 (= 9))))
Available in repositories: 4.x

Version 1.9: Migrated to scrbl docs; added windows search path from David Gray.

Version 1.8: Migrated to #lang scheme; fixed bug related to improperly named srfi-1 imports.

Version 1.7: Now searches for libraries on Windows.

Version 1.6: Added some new tests, now export structure type for matrix as s:matrix

Version 1.4: Thanks to Noel Welsh, now finds libraries on linux, too. Complete bindings to BLAS single- and double-precision operations in "blas-lapack.ss"

Version 1.3: Looks for libraries in more places---should now run on any system with libLAPACK and libBLAS installed in standard places.

Version 1.2: Fixed major bug in :matrix

Version 1.1: Only works in Mac OS 10.[3,4].

(1 8)
8
[none]2008-11-12
To load: (require (planet "all.ss" ("wmfarr" "plt-linalg.plt" 1 (= 8))))
Available in repositories: 4.x

Version 1.8: Migrated to #lang scheme; fixed bug related to improperly named srfi-1 imports.

Version 1.7: Now searches for libraries on Windows.

Version 1.6: Added some new tests, now export structure type for matrix as s:matrix

Version 1.4: Thanks to Noel Welsh, now finds libraries on linux, too. Complete bindings to BLAS single- and double-precision operations in "blas-lapack.ss"

Version 1.3: Looks for libraries in more places---should now run on any system with libLAPACK and libBLAS installed in standard places.

Version 1.2: Fixed major bug in :matrix

Version 1.1: Only works in Mac OS 10.[3,4].

(1 7)
77
[none]2008-02-19
To load: (require (planet "all.ss" ("wmfarr" "plt-linalg.plt" 1 (= 7))))
Available in repositories: 4.x, 3xx

Version 1.7: Now searches for libraries on Windows.

Version 1.6: Added some new tests, now export structure type for matrix as s:matrix

Version 1.4: Thanks to Noel Welsh, now finds libraries on linux, too. Complete bindings to BLAS single- and double-precision operations in "blas-lapack.ss"

Version 1.3: Looks for libraries in more places---should now run on any system with libLAPACK and libBLAS installed in standard places.

Version 1.2: Fixed major bug in :matrix

Version 1.1: Only works in Mac OS 10.[3,4].

(1 6)1.6
6
[none]2008-02-13
To load: (require (planet "all.ss" ("wmfarr" "plt-linalg.plt" 1 (= 6))))
Available in repositories: 4.x, 3xx

Version 1.6: Added some new tests, now export structure type for matrix as s:matrix

Version 1.4: Thanks to Noel Welsh, now finds libraries on linux, too. Complete bindings to BLAS single- and double-precision operations in "blas-lapack.ss"

Version 1.3: Looks for libraries in more places---should now run on any system with libLAPACK and libBLAS installed in standard places.

Version 1.2: Fixed major bug in :matrix

Version 1.1: Only works in Mac OS 10.[3,4].

(1 5)1.4
52
[none]2007-05-25
To load: (require (planet "all.ss" ("wmfarr" "plt-linalg.plt" 1 (= 5))))
Available in repositories: 4.x, 3xx

Version 1.4: Thanks to Noel Welsh, now finds libraries on linux, too. Complete bindings to BLAS single- and double-precision operations in "blas-lapack.ss"

Version 1.3: Looks for libraries in more places---should now run on any system with libLAPACK and libBLAS installed in standard places.

Version 1.2: Fixed major bug in :matrix

Version 1.1: Only works in Mac OS 10.[3,4].

(1 4)1.4
3
[none]2007-05-25
To load: (require (planet "all.ss" ("wmfarr" "plt-linalg.plt" 1 (= 4))))
Available in repositories: 3xx, 4.x

Version 1.4: Thanks to Noel Welsh, now finds libraries on linux, too. Complete bindings to BLAS single- and double-precision operations in "blas-lapack.ss"

Version 1.3: Looks for libraries in more places---should now run on any system with libLAPACK and libBLAS installed in standard places.

Version 1.2: Fixed major bug in :matrix

Version 1.1: Only works in Mac OS 10.[3,4].

(1 3)1.3
7
[none]2007-05-10
To load: (require (planet "all.ss" ("wmfarr" "plt-linalg.plt" 1 (= 3))))
Available in repositories: 4.x, 3xx

Version 1.3: Looks for libraries in more places---should now run on any system with libLAPACK and libBLAS installed in standard places.

Version 1.2: Fixed major bug in :matrix

Version 1.1: Only works in Mac OS 10.[3,4].

(1 2)1.2
5
[none]2007-05-01
To load: (require (planet "all.ss" ("wmfarr" "plt-linalg.plt" 1 (= 2))))
Available in repositories: 3xx, 4.x
Only works for Mac OS X 10.y, y >= 3. Fixed major bug in :matrix.
(1 1)1.1
6
[none]2007-04-28
To load: (require (planet "all.ss" ("wmfarr" "plt-linalg.plt" 1 (= 1))))
Available in repositories: 4.x, 3xx
Only works for Mac OS X 10.y, y >= 3
(1 0)1.0
6
[none]2007-04-26
To load: (require (planet "all.ss" ("wmfarr" "plt-linalg.plt" 1 (= 0))))
Available in repositories: 4.x, 3xx
Only works for Mac OS X 10.y, y >= 3